ドキュメント

移動と変形

操作ツールでレイヤーや選択した画素を移動し、変形で拡大縮小、回転、傾斜、自由なゆがみ、メッシュ変形を加えられます。

操作ツール

次のいずれかの操作を行います。

  • レイヤーパネルでレイヤーメニューを開き、レイヤー/マスクを移動を選びます。
  • Oを押します。
  • 「ペイント」と「写真」では、「ツール」ツールバーで操作 / 変形を選択します。ボタンを右クリックまたは長押しして、操作を選びます。
  • コマンド検索に「操作」と入力します。

「スケッチ」には、操作ボタンはありません。

レイヤーの移動

選択範囲がないときは、キャンバス上をドラッグして、選択中のレイヤーを移動します。矢印キーでは1 px、Shiftを押しながらでは10 pxずつ動きます。

ロックされたレイヤーは移動できません。

選択した画素の移動

選択範囲があるときは、ドラッグすると、編集中のペイントレイヤーの選択した画素を1ピクセル単位で移動します。マスクの編集中は、操作でマスクを移動します。

ガイドを表示しているときは、操作でガイドの選択とドラッグもできます(定規とガイドを参照)。

コピーを残す

選択した画素のコピーを移動し、元の画素をその場に残せます。

ツールパネル、または選択範囲バーで、コピーを残すをオンにします。ドラッグを始めるときにAltを押したままにすると、そのドラッグだけ逆の動作になります。

変形

次のいずれかの操作を行います。

  • 編集 > 変形を選びます。
  • Ctrl+Tを押します。
  • 「ペイント」と「写真」では「コマンド」ツールバー、「スケッチ」ではタイトルバーで、変形を選択します。
  • 選択範囲バーの変形を選択します。
  • 「ペイント」と「写真」では、「ツール」ツールバーの操作 / 変形を右クリックまたは長押しし、変形を選びます。

選択範囲があるときは、変形は編集中のレイヤーまたはマスクの選択した画素を変えます。選択範囲がないときは、選択中のレイヤーを変えます。ハンドル付きのボックスとキャンバス操作バーが表示されます。

終えるには、適用を選択するかEnterを押します。キャンセルまたはEscapeで、変形を破棄します。レイヤーの変形中は、元に戻すでも破棄できます。

複数のレイヤーを変形するには、先に選択範囲を解除します。

ハンドル

自由と縦横比を維持では、次の操作ができます。

  • ボックスの内側をドラッグすると、ボックスを移動します。Shiftを押したままにすると、水平または垂直にだけ動きます。
  • 角や辺のハンドルをドラッグすると、反対側を基準に拡大縮小します。Shiftを押したままにすると縦横比を保ち、Altを押したままにすると基準点を中心に拡大縮小します。
  • Ctrlを押したまま辺のハンドルをドラッグすると、最大85°まで傾斜します。
  • 上辺の上にあるハンドルをドラッグすると、基準点を中心に回転します。Shiftを押したままにすると、15°単位になります。
  • 基準点をドラッグすると、基準点を移動します。

自由なゆがみでは、次の操作ができます。

  • 角をドラッグすると、その角だけを動かします。辺のハンドルをドラッグすると、その辺を動かします。
  • 角でShiftを押したままにすると、隣の角に動きを反転して反映し、左右対称の遠近になります。

メッシュ変形では、次の操作ができます。

  • メッシュの点と、選択した点の接線のハンドルをドラッグします。
  • 点をShift+クリックすると、複数の点をまとめて動かせます。

すべてのモードで、次の操作ができます。

  • 矢印キーでは1 px、Shiftを押しながらでは10 pxずつ、ボックスを動かします。
  • タッチスクリーンでは、ハンドルやボックスの内側に置いた指でドラッグします。それ以外の場所に置いた指では、表示が動きます。

変形のバー

変形用のキャンバス操作バー。モード、スナップ、反転と回転のボタン、リセット、補間、キャンセル、適用があります。

モード

自由、縦横比を維持、自由なゆがみ、メッシュ変形。縦横比を維持は縦横比を保ちます。レイヤーの変形は、縦横比を維持で始まります。

元のサイズ

配置した写真を100%に戻します。自由なゆがみもメッシュ変形もかけていない写真でのみ使えます。

スナップ

ボックスの辺と中心を、キャンバス、ほかの表示中のレイヤー、ガイドにスナップします。回転はスナップしません。初期設定はオフです。

遠近変形

自由なゆがみで、角のドラッグを反転して隣の角にも反映します。

メッシュ変形のグリッド

メッシュ変形では、次の項目を使えます。

  • グリッドを分割:垂直に分割、水平に分割、十字に分割のいずれかを選び、メッシュをタップすると、形を変えずにその位置にグリッド線を追加します。Escapeで分割をキャンセルします。グリッドは、各方向に最大32区画です。
  • ポイントを選択:点をタップして選択し、まとめて動かします。
  • グリッドをリセット:メッシュ変形を、まっすぐなグリッドに置き換えます。
  • グリッド:3 × 3(初期設定)、4 × 4、5 × 5。形を変えるまで使えます。
メッシュ変形モードのキャンバス操作バー。グリッドを分割、ポイントを選択、グリッドをリセット、グリッドがあります。

反転と回転のボタン

アイコンのボタン左右反転、上下反転、左に90°回転、右に90°回転は、基準点を中心に内容を反転または回転します。

リセット

この変形で加えた変更をすべて取り消し、変形は開いたままにします。モードは自由に戻ります。

補間

画素の再サンプリング方法を、最近傍、バイリニア、バイキュービック、Lanczosから設定します。初期設定は、自由と縦横比を維持ではバイリニア、自由なゆがみとメッシュ変形ではバイキュービックです。

ツールパネルの変形の値

ツールパネルと、「写真」の「ツールのオプション」バーには、変形中の値が表示されます(メッシュ変形を除く)。

  • 位置の基準点:XとY(ピクセル単位)。上にある基準点のグリッドで、ボックスのどの点の値を表示するかを選びます。
  • 拡大縮小:幅と高さ(パーセント)。縦横比を維持では、2つの値が連動します。
  • 回転:角度(−180°から180°まで)。
  • 傾斜:傾斜(−85°から85°まで)。
変形中のツールパネル。位置の基準点、拡大縮小、回転、傾斜があります。

レイヤーの変形

ペイントレイヤーや写真レイヤー全体の変形は各レイヤーに保存され、画素は再サンプリングされません。変形をもう一度開くと、保存された変形から始まります。

変形を画素に適用するまでは、拡大縮小や回転をしたレイヤーはレタッチできず、自由なゆがみやメッシュ変形をかけたレイヤーには描画できません。

変形をピクセルに適用

レイヤーに保存された変形を、画素に反映できます。

次のいずれかの操作を行います。

  • 編集 > 変形をピクセルに適用を選びます。
  • レイヤー > レイヤー設定 > 変形をピクセルに適用を選びます。

処理中は、キャンバス下部のバーに「変形を適用中…」とキャンセルが表示されます。

変形を繰り返す

選択範囲がないときに編集 > 変形を繰り返すを選ぶと、最後のレイヤーの変形を選択中のレイヤーに適用します。貼り付け、読み込み、選択した画素の変形は繰り返されません。

配置した画像

ほかのアプリから画像を貼り付けるか、ファイル > 画像をレイヤーとして読み込む… を選ぶと、画像が変形ボックスに入った状態で開きます。適用で画像を配置し、キャンセルで画像を取り除きます。どちらかを選ぶまで、ほかのコマンドは使えません。