文件

移動與變形

可以用動作工具移動圖層和選取的像素,並用變形對其進行縮放、旋轉、斜切、扭曲或網格變形。

操作工具

執行以下任一操作:

  • 在圖層面板中開啟某個圖層的選單,選擇移動圖層/遮罩。
  • 按 O。
  • 在「繪畫」和「照片」中,選擇「工具」工具列中的操作/變形。右鍵按一下或按住該按鈕可選擇動作。
  • 在命令搜尋中輸入「操作」。

「素描」中沒有動作按鈕。

移動圖層

沒有選取範圍時,在畫布上拖動可移動所選圖層。方向鍵每次微移 1 px,按住 Shift 時微移 10 px。

不能移動已鎖定的圖層。

移動選取的像素

有選取範圍時,拖動可按整像素步長移動目前繪畫圖層中選取的像素。編輯遮罩時,動作移動的是遮罩。

顯示輔助線時,動作也可以選擇和拖動輔助線(參見尺規和輔助線)。

保留副本

可以移動選取像素的副本,同時將原像素保留在原位。

在工具設定面板或選取範圍操作欄上開啟保留副本。開始拖動時按住 Alt,可在這一次拖動中執行相反的操作。

變形

執行以下任一操作:

  • 選擇編輯 > 變形。
  • 按 Ctrl+T。
  • 選擇變形,它在「繪畫」和「照片」中位於「命令」工具列,在「素描」中位於標題列。
  • 選擇選取範圍操作欄上的變形。
  • 在「繪畫」和「照片」中,右鍵按一下或按住「工具」工具列中的操作/變形,然後選擇變形。

有選取範圍時,變形更改目前圖層或遮罩中選取的像素。沒有選取範圍時,它更改所選圖層。畫布上會出現帶控制點的變形框和畫布操作欄。

要完成,選擇套用或按 Enter。取消或 Escape 會放棄變形;變形圖層時,復原也會放棄變形。

要變形多個圖層,先清除選取範圍。

控制點

在自由和等比模式下:

  • 在框內拖動可移動變形框。按住 Shift 只沿水平或垂直方向移動。
  • 拖動角或邊上的控制點,從對側開始縮放。按住 Shift 維持比例,按住 Alt 圍繞中心點縮放。
  • 按住 Ctrl 拖動邊上的控制點可斜切,最多 85°。
  • 拖動上邊緣上方的控制點,圍繞中心點旋轉。按住 Shift 以 15° 為步長旋轉。
  • 拖動中心點可移動其位置。

在扭曲模式下:

  • 拖動一個角可單獨移動該角,拖動邊上的控制點可移動該邊。
  • 在角上按住 Shift,相鄰的角會做映象移動,形成對稱透視。

在網格變形模式下:

  • 拖動網格點,以及所選點的切線控制柄。
  • 按住 Shift 點按多個點,可一起移動。

在所有模式下:

  • 方向鍵每次將變形框微移 1 px,按住 Shift 時微移 10 px。
  • 在觸控式螢幕上,手指放在控制點上或框內時拖動變形框。手指放在其他位置時移動檢視。

變形欄

變形的畫布操作欄,包含模式、吸附、翻轉和旋轉按鈕、重置、插值、取消和應用。

模式

自由、等比、扭曲或網格變形。等比維持比例。圖層變形以等比模式開啟。

原始大小

將置入的照片恢復到 100%。僅適用於未使用扭曲或網格變形的照片。

吸附

將變形框的邊緣和中心吸附到畫布、其他可見圖層和輔助線。旋轉不會吸附。預設關閉。

透視

使用扭曲時,將每次拖動角的操作映象到相鄰的角。

變形網格

使用網格變形時:

  • 分割網格:選擇垂直分割、水平分割或十字分割,然後輕點變形區域,在該處新增一條網格線而不改變形狀。Escape 取消拆分。網格在每個方向上最多可有 32 個單元格。
  • 選取控制點:輕點控制點將其選取,並一起移動。
  • 重設網格:用平直網格替換目前變形。
  • 網格:3 × 3(預設)、4 × 4 或 5 × 5。更改形狀之前可用。
網格變形模式下的畫布操作欄,包含分割網格、選取控制點、重設網格和網格。

翻轉和旋轉按鈕

圖示按鈕水平翻轉、垂直翻轉、左轉 90° 和右轉 90° 圍繞中心點映象或旋轉內容。

重設

復原本次變形中所做的所有更改,並保持變形開啟。模式恢復為自由。

內插

設定像素的重新取樣方式:最鄰近、雙線性、雙三次或 Lanczos。在自由和等比模式下預設為雙線性,在扭曲和網格變形模式下預設為雙三次。

工具設定面板中的變形數值

工具設定面板以及「照片」中的工具選項欄會顯示開啟的變形的數值,網格變形模式除外。

  • 位置參考點:X 和 Y,以像素為單位,上方的參考點網格決定它們給出的是變形框的哪一點。
  • 縮放:寬度和高度,以百分比為單位。等比使兩者保持連結。
  • 旋轉:角度,範圍為 −180° 到 180°。
  • 斜切:斜切,範圍為 −85° 到 85°。
變形期間的工具設定面板,包含位置參考點、縮放、旋轉和斜切。

圖層變形

對整個繪畫圖層或照片圖層的變形會隨各圖層儲存,像素不會被重新取樣。再次開啟變形時,會從儲存的變形繼續。

在將變形套用至像素之前,不能修飾已縮放或旋轉的圖層,也不能在已扭曲或網格變形的圖層上繪畫。

將變形套用至像素

可以將圖層儲存的變形變為其像素的一部分。

執行以下任一操作:

  • 選擇編輯 > 將變形套用至像素。
  • 選擇圖層 > 圖層設定 > 將變形套用至像素。

處理期間,畫布底部的欄顯示「正在套用變形…」和取消。

再次變形

沒有選取範圍時,選擇編輯 > 再次變形,可將上一次圖層變形應用到所選圖層。貼上、匯入以及對選取像素的變形不會重複。

置入的影像

從其他應用程式貼上影像或選擇檔案 > 將影像匯入為圖層… 時,影像會在變形框中開啟。套用置入影像,取消移除影像。在選擇其中之一之前,其他命令無法使用。