文档

移动和变换

可以用操作工具移动图层和选中的像素,并用变换对其进行缩放、旋转、斜切、扭曲或网格变形。

操作工具

执行以下任一操作:

  • 在图层面板中打开某个图层的菜单,选择移动图层/蒙版。
  • 按 O。
  • 在“绘画”和“照片”中,选择“工具”工具栏中的操作/变换。右键单击或按住该按钮可选择操作。
  • 在命令搜索中输入“操作”。

“素描”中没有操作按钮。

移动图层

没有选区时,在画布上拖动可移动所选图层。方向键每次微移 1 px,按住 Shift 时微移 10 px。

不能移动已锁定的图层。

移动选中的像素

有选区时,拖动可按整像素步长移动当前绘画图层中选中的像素。编辑蒙版时,操作移动的是蒙版。

显示辅助线时,操作也可以选择和拖动辅助线(参见标尺和辅助线)。

保留副本

可以移动选中像素的副本,同时将原像素保留在原位。

在工具设置面板或选区操作栏上打开保留副本。开始拖动时按住 Alt,可在这一次拖动中执行相反的操作。

变换

执行以下任一操作:

  • 选择编辑 > 变换。
  • 按 Ctrl+T。
  • 选择变换,它在“绘画”和“照片”中位于“命令”工具栏,在“素描”中位于标题栏。
  • 选择选区操作栏上的变换。
  • 在“绘画”和“照片”中,右键单击或按住“工具”工具栏中的操作/变换,然后选择变换。

有选区时,变换更改当前图层或蒙版中选中的像素。没有选区时,它更改所选图层。画布上会出现带控制点的变换框和画布操作栏。

要完成,选择应用或按 Enter。取消或 Escape 会放弃变换;变换图层时,撤销也会放弃变换。

要变换多个图层,先清除选区。

控制点

在自由和等比模式下:

  • 在框内拖动可移动变换框。按住 Shift 只沿水平或垂直方向移动。
  • 拖动角或边上的控制点,从对侧开始缩放。按住 Shift 保持比例,按住 Alt 围绕中心点缩放。
  • 按住 Ctrl 拖动边上的控制点可斜切,最多 85°。
  • 拖动上边缘上方的控制点,围绕中心点旋转。按住 Shift 以 15° 为步长旋转。
  • 拖动中心点可移动其位置。

在扭曲模式下:

  • 拖动一个角可单独移动该角,拖动边上的控制点可移动该边。
  • 在角上按住 Shift,相邻的角会做镜像移动,形成对称透视。

在网格变形模式下:

  • 拖动网格点,以及所选点的切线控制柄。
  • 按住 Shift 点按多个点,可一起移动。

在所有模式下:

  • 方向键每次将变换框微移 1 px,按住 Shift 时微移 10 px。
  • 在触摸屏上,手指放在控制点上或框内时拖动变换框。手指放在其他位置时移动视图。

变换栏

变换的画布操作栏,包含模式、吸附、翻转和旋转按钮、重置、插值、取消和应用。

模式

自由、等比、扭曲或网格变形。等比保持比例。图层变换以等比模式打开。

原始大小

将置入的照片恢复到 100%。仅适用于未使用扭曲或网格变形的照片。

吸附

将变换框的边缘和中心吸附到画布、其他可见图层和辅助线。旋转不会吸附。默认关闭。

透视

使用扭曲时,将每次拖动角的操作镜像到相邻的角。

变形网格

使用网格变形时:

  • 拆分网格:选择垂直拆分、水平拆分或十字拆分,然后轻点变形区域,在该处添加一条网格线而不改变形状。Escape 取消拆分。网格在每个方向上最多可有 32 个单元格。
  • 选择控制点:轻点控制点将其选中,并一起移动。
  • 重置网格:用平直网格替换当前变形。
  • 网格:3 × 3(默认)、4 × 4 或 5 × 5。更改形状之前可用。
网格变形模式下的画布操作栏,包含拆分网格、选择控制点、重置网格和网格。

翻转和旋转按钮

图标按钮水平翻转、垂直翻转、左转 90° 和右转 90° 围绕中心点镜像或旋转内容。

重置

撤销本次变换中所做的所有更改,并保持变换打开。模式恢复为自由。

插值

设置像素的重新采样方式:最近邻、双线性、双三次或 Lanczos。在自由和等比模式下默认为双线性,在扭曲和网格变形模式下默认为双三次。

工具设置面板中的变换数值

工具设置面板以及“照片”中的工具选项栏会显示打开的变换的数值,网格变形模式除外。

  • 位置参考点:X 和 Y,以像素为单位,上方的参考点网格决定它们给出的是变换框的哪一点。
  • 缩放:宽度和高度,以百分比为单位。等比使两者保持链接。
  • 旋转:角度,范围为 −180° 到 180°。
  • 斜切:斜切,范围为 −85° 到 85°。
变换期间的工具设置面板,包含位置参考点、缩放、旋转和斜切。

图层变换

对整个绘画图层或照片图层的变换会随各图层存储,像素不会被重新采样。再次打开变换时,会从存储的变换继续。

在将变换应用于像素之前,不能修饰已缩放或旋转的图层,也不能在已扭曲或网格变形的图层上绘画。

将变换应用于像素

可以将图层存储的变换变为其像素的一部分。

执行以下任一操作:

  • 选择编辑 > 将变换应用于像素。
  • 选择图层 > 图层设置 > 将变换应用于像素。

处理期间,画布底部的栏显示“正在应用变换…”和取消。

再次变换

没有选区时,选择编辑 > 再次变换,可将上一次图层变换应用到所选图层。粘贴、导入以及对选中像素的变换不会重复。

置入的图像

从其他应用粘贴图像或选择文件 > 将图像导入为图层… 时,图像会在变换框中打开。应用置入图像,取消移除图像。在选择其中之一之前,其他命令不可用。