ドキュメント

選択範囲レイヤー

選択範囲をレイヤーとしてレイヤーパネルに保存し、あとで再び読み込めます。

選択範囲の保存

次のいずれかの操作を行います。

  • 選択範囲 > 選択範囲レイヤーとして保存を選びます。
  • 選択範囲バーまたはクイックマスクのバーの保存を選択します。
  • クイックマスク中に、レイヤー > 選択範囲レイヤーとして保存を選びます。

新しいレイヤーはレイヤーリストのいちばん上に追加され、選択範囲に番号を付けた名前が付きます。レイヤーは編集できる状態で開き、すぐに名前を入力できます。クイックマスクから保存すると、クイックマスクの重ね表示の色と不透明度も保存されます。

グループ内に保存するには、グループのメニューを開き、現在の選択範囲をグループ内に保存… を選びます。

新規選択範囲レイヤー

空の選択範囲レイヤーを作り、選択範囲を描けます。

次のいずれかの操作を行います。

  • 選択範囲 > 新規選択範囲レイヤーを選びます。
  • レイヤーパネル下部の新規選択範囲レイヤーを選択します。
  • グループのメニューを開き、グループ内に新規選択範囲レイヤー… を選びます。

選択範囲レイヤーの行

選択範囲レイヤーの行には、選択範囲のサムネイル、重ね表示を表示または非表示にする目のボタン、サムネイルの横の読み込みボタンがあります。

行を選択すると、レイヤーが編集できる状態で開きます。選択範囲レイヤーには不透明度、合成モード、マスクがなく、結合できません。編集中以外は描画もできません。

レイヤーパネルの選択範囲レイヤーの行。サムネイルの横に読み込みボタンがあります。

選択範囲レイヤーの編集

選択範囲レイヤーの編集中は、クイックマスクと同じように、ブラシ、塗りつぶし、グラデーションで保存した選択範囲を変更します。プロパティパネルには、レイヤーの重ね表示の色と重ね表示の不透明度、共通のモードが表示されます。

キャンバス下部のキャンバス操作バーには、「レイヤー名」を編集中という見出しが付きます。キャンバス操作バーを隠しているときは、このバーは表示されません。

  • 読み込みは、レイヤーを現在の選択範囲にして、作品に戻ります。
  • 反転は、保存した選択範囲を反転し、レイヤーを編集できる状態のままにします。
  • 作品に戻るで、編集を終了します。Escapeでも同じです。

編集を終えると、その前に編集していたレイヤーが再び編集中のレイヤーになります。そのようなレイヤーがない場合は、いちばん上のペイントレイヤーになります。

保存した選択範囲を調整するには、選択範囲レイヤーのメニューを開き、変更から選びます。選択範囲 > 選択範囲を拡張… など選択範囲メニューの調整コマンドは、先に作品に戻ってから、現在の選択範囲を変更します。

編集中の選択範囲レイヤーのキャンバス操作バー。読み込み、反転、作品に戻るがあります。

選択範囲レイヤーの読み込み

次のいずれかの操作を行います。

  • 選択範囲 > 選択範囲を読み込むを選んでレイヤーを選び、選択範囲を読み込む、選択範囲に追加、選択範囲から削除、選択範囲との共通範囲、反転した選択範囲を読み込むのいずれかを選びます。
  • レイヤーの行の読み込みボタンを選択します。
  • Ctrlを押したまま、レイヤーのサムネイルをクリックします。Shiftを加えると追加、Altを加えると削除、Shift+Altを加えると共通範囲になります。
  • レイヤーの編集中に、キャンバス操作バーの読み込みを選択します。

読み込むと、まず作品に戻ります。選択範囲レイヤーはそのまま残ります。グループ内のレイヤーは、選択範囲を読み込むの中に、グループ 1 / 選択範囲 1のようなグループのパスで表示されます。

選択範囲レイヤーの置き換え

現在の選択範囲を既存の選択範囲レイヤーに保存するには、選択範囲 > 現在の選択範囲で選択範囲レイヤーを置き換えるを選び、レイヤーを選びます。ロックされた選択範囲レイヤーは置き換えられません。

選択範囲レイヤーのメニュー

選択範囲レイヤーの行を右クリックまたは長押しすると、メニューが開きます。

  • 選択範囲を読み込む:選択範囲メニューと同じ5つの項目。
  • 変更:現在の選択範囲で置換、反転、すべて選択、消去、塗りつぶし、拡張…、縮小…、ぼかし…、境界線…、滑らかにする…。
  • 整理:選択したレイヤーをグループ化、最上位に移動、上に移動、下に移動、グループ内に移動。
  • 名前を変更…、複製、削除、編集をロック。ロックされたレイヤーでは、編集をロックが編集のロックを解除になります。

ロックされた選択範囲レイヤーでは、変更は使えません。複数のレイヤーを選択しているときは、メニューに選択したレイヤーを複製と選択したレイヤーを削除が表示されます。