ドキュメント

元に戻す・やり直す

作品への変更を1ステップずつ取り消し、取り消したステップをやり直せます。開いている作品には、それぞれ専用の履歴があります。

「コマンド」ツールバーの元に戻すボタンとやり直すボタン。

元に戻す

次のいずれかの操作を行います。

  • 編集 > 元に戻すを選びます。
  • Ctrl+Zを押します。
  • 「コマンド」ツールバーの元に戻すを選択します。「スケッチ」では、元に戻すは画面左端のバーにあります。
  • キャンバスを2本の指でタップします。

やり直す

次のいずれかの操作を行います。

  • 編集 > やり直すを選びます。
  • Ctrl+Shift+ZまたはCtrl+Yを押します。
  • 「コマンド」ツールバーのやり直すを選択します。「スケッチ」では左端のバーにあります。
  • キャンバスを3本の指でタップします。

元に戻した後で新しい変更を加えると、やり直せるステップは消去されます。

1ステップとして記録される操作

ストローク、塗りつぶし、フィルターの変更、変形、切り抜き、キャンバスサイズの変更、選択範囲の変更は、それぞれ1ステップです。レイヤーへの変更も、1回ごとに1ステップになります。表示、ツール、ブラシ、色、レイアウトの変更はステップになりません。

画像の配置中、レイヤーの変形中、切り抜きツールの使用中は、「元に戻す」を実行すると、1ステップ戻る代わりにその操作がキャンセルされます。

履歴の長さ

各作品には最大256ステップが保持されます。古いステップから順に破棄されます。

保存と開き直し

保存しても履歴は消去されません。.capyファイルから開いた作品は空の履歴で始まります。カピカンの再起動時に開き直される作品は、取り消しのステップを保持しています。

レイアウトの変更

パネル、ツールバー、タイトルバー、ワークスペースへの変更には、専用の履歴があります。編集 > 元に戻すでレイアウトの変更が取り消されることはありません。

次のいずれかの操作を行います。

  • ウィンドウ > レイアウトの変更を元に戻すまたはウィンドウ > レイアウトの変更をやり直すを選びます。
  • Ctrl+Alt+ZまたはCtrl+Alt+Shift+Zを押します。

ワークスペースはそれぞれ専用のレイアウト履歴を持ち、履歴は再起動後も残ります。ウィンドウ > ワークスペース > レイアウト履歴… には、現在のワークスペースの以前のレイアウトが一覧表示されます。