ドキュメント

フィルターの適用のしくみ

フィルターは、それ自体には描画を持たないレイヤーです。設定は、プロパティパネルでいつでも変更できます。

テラリウムの写真にトーンカーブと明瞭度を関連付け、その上の単独のレイヤーに周辺光量補正のフィルターがあるレイヤーパネル。
単独のレイヤーのフィルター 関連付けたフィルター
追加方法 フィルターパネル、フィルターメニュー、選択範囲バーの調整 フィルターを追加
効果の範囲 グループ内でその下にあるすべてのレイヤー 関連付け先のレイヤーだけ
レイヤーパネルでの表示 独立した行 鎖のアイコンで下の行とつながった行

単独のレイヤーのフィルター

新しいフィルターは、選択中のレイヤーと、そこにクリッピングまたは関連付けられたレイヤーの上に追加されます。グループ内では、フィルターはそのグループ内で下にあるレイヤーだけを変えます。ただし、グループが通過に設定されている場合は除きます。

関連付けたフィルター

フィルターは、ペイントレイヤー、写真レイヤー、通過に設定していないグループに関連付けられます。レイヤーを選択し、レイヤーパネルまたはプロパティパネルの下部、あるいはレイヤーメニューでフィルターを追加を選択します。

関連付けたフィルターは、つながりの下から順に適用されます。適用されるのは、レイヤーのマスクの後、不透明度と合成モードの前です。クリッピングのベースレイヤーでは、クリッピングされたレイヤーが表示される範囲も変わります。ガウスぼかしや渦巻きなどのぼかしやゆがみは、レイヤーの描画を輪郭の外まで広げることがあります。

レイヤーを移動、複製、非表示にすると、関連付けたフィルターにも同じ操作が行われます。レイヤーを削除すると、関連付けたフィルターは単独のレイヤーのフィルターとして残ります。

レイヤー名に適用と下のレイヤーに適用

選択中のフィルターを、2つの種類の間で切り替えられます。

次のいずれかの操作を行います。

  • レイヤー > レイヤー設定 > レイヤー名に適用または下のレイヤーに適用を選びます。
  • レイヤーパネルのヘッダーで、下のレイヤーでクリッピングの位置にある鎖のボタンを選択します。
  • フィルターをレイヤーのサムネイルにドラッグすると、そのレイヤーに関連付けられます。
選択中のフィルター用の鎖のボタンがある、レイヤーパネルのヘッダー。

レイヤー名に適用は、フィルターを下にある最も近いレイヤーに関連付けます。下のレイヤーに適用は、フィルターを単独のレイヤーにして、関連付けていたレイヤーとそこにクリッピングされたレイヤーの上に置きます。

フィルターまたは下のレイヤーがロックされている間は、ボタンを使用できません。下のレイヤーがペイントレイヤー、写真レイヤー、グループのいずれでもないときは、ボタンのツールチップに「関連付け先となる下のレイヤーがありません」と表示されます。

選択範囲をフィルターのマスクにする

フィルターを追加するときに選択範囲があると、その選択範囲がフィルターのマスクになります。元に戻すを1回行うと、フィルターが削除され、選択範囲が戻ります。

下のレイヤーに効果を適用

フィルターを描画として、その下のレイヤーに結合できます。

フィルターを選択し、次のいずれかの操作を行います。

  • レイヤー > 下のレイヤーに効果を適用を選ぶか、フィルターのレイヤーメニューから同じ項目を選びます。
  • Ctrl+Eを押します。
下のレイヤーに効果を適用があるフィルターのレイヤーメニュー。

単独のレイヤーのフィルターは、すぐ下のレイヤーにだけ適用されます。関連付けたフィルターでは、レイヤーとフィルターのつながり全体が描画になります。そのレイヤーがクリッピングされているか、クリッピングされたレイヤーを持つ場合は、コマンドがクリッピングされたレイヤーを結合になります(レイヤーの結合を参照)。

フィルターと下のレイヤーは、表示中で、ロックされておらず、通常に設定されている必要があります。すぐ下のレイヤーが、ほかのレイヤーに関連付けられたフィルターの場合は、このコマンドを使えません。